I realize this post is 3 years old now - however it is still available on the web, and its the first time I've read it.
So.. I would like to take issue with your "start with bevity".
Firstly, you should never write code for the compiler, obviously. You should also never write code that "starts with brevity". I'm one of those that will fight you tooth and nail and say that String.Empty is better, by FAR!, than "". As I'm reading a line of code I dont have to stop and translate 'if (someVariable != "")' into 'if some variable not equal to an empty string'. Using String.Empty there just makes it easier to read.
And that's the thing.. one should always wrote code for the HUMAN READER: the next guy that comes along to maintain/tweak/etc your code - even if its you in 6 months.