XP Automatic Update Nagging

Having a pop up is a little annoying. But my first experience of it was setting a 3-day data processing task going and then going out of town for a week. I returned to find my computer had re-booted a few minutes after going out the door!

If the pop-up had conveyed ‘restart later’ wasn’t the usual ‘I will restart later’, or there was a third option for manual restart, I wouldn’t have lost an important client.

You’d think when the clever guys at MS put in an option to force a reboot of an unattended computer, such a possibility would have been clear.

“Raaabo… XP Home doesn’t have a group policy editor. That solution is only for XP Pro users. Considering that XP Home is the single most popular personal computer operating system in the history of the world, your outrage seems misplaced. - slimy”

Really? You mean XP Home actually sold more than XP Pro?? Any idea on the stats of the most popular “free” XP version :wink: Since those “free” users make up a majority of the comp users worldwide!

Anyway, I need an XP Home volunteer to try something out… Remember, I know nothing and I might cause you to have to format and reinstall Windows, so don’t flame me if you screw up your system doing what I say…

I would do this myself to test it but I cannot find an XP Home CD anywhere… paid OR “free”:

Open the registry editor… Navigate to :


See if a folder called AU exists. If it doesn’t, create one: New Key AU

Now Create the following inside this folder:

DWORD Value: NoAutoRebootWithLoggedOnUsers | Hexadecimal value 1

DWORD Value: RebootRelaunchTimeout | Hexadecimal value b4

DWORD Value: RebootRelaunchTimeoutEnabled | Hexadecimal value 1

If someone with XP Home, time to kill and no important data could verify whether this works or not, I’d be eternally grateful!



my problem was odd, I’m running XP pro under an admin acount, well the admin account, byt gpedit.msc doesn’t work on this computer. I get an error about not having the right privillages. XP pro doesn’t have the same registry entries that home does so I couldn’t do that. the CMD command does work though, thank you for whoever thought of that and mentioned it.


so glad i found this… so annoying.

Thanks for the great tips. Not only do I get the annoying popup box that asks if I want to reboot, but just as I was about to leave my PC unattended a box popped up with a countdown timer set to something like 3 minutes; had I not clicked on ‘reboot later’ it would’ve taken the liberty to do so and trashed hours of work. Who thought this one out at Microsoft? Shame on you.

My question is, will your fixes take care of the popups even if you manually run updates on the MS website and install them? I’ve disabled the service and so far it seems to have done the trick. Looking at the values in the GPE, they all refer to ‘scheduled’ and ‘automatic’ updates, I wonder if they also work with manually initiated ones.


Bill Gates knows what you want.
Listen to Bill Gates.
He is your friend.
Trust him.
Do what he wants.
Be one with Windows.

@Raabo: Apparantly it doesn’t work in Win XP Home, it displays the message every 10 minutes, and the only way to stop it is to kill the service.

The easiest and fastest way to stop the nag until YOU reboot is to select “Start”, “Run”, copy and paste this in: net stop wuauserv

Select “OK”

That was imbedded in the update http://www.codinghorror.com/blog/archives/000294.html near the bottom of method #1 and is what is referred to as the “command line”.

Apparently I got a non-genuine copy of XP.I wasn’t able to activate windows. There is a way to dis-able the windows update so I can continue to use it in my home computer? after allm I paid for the software

genius - thankyou very much :slight_smile:

Thank you Thank you Thank you to all who were helpful here :smiley: :smiley: :smiley:

Stupid thing kept popping up asking to restart now or restart later with a 5 minute timer set to restart automatically. Pushing the window to the side would have been like moving a time bomb from the lunch room to the basement, its still going to go off. Solution 1 worked for me, by stopping the service. Then I went to start control panel security settings manage security settings for: automatic updates Download updates for me, but let me choose when to install them.

There, fixed forever!

I cannot thank you folks enough for this information. Like at least one other poster here, I once had my computer rebooted by this appalling “feature” while I was away and couldn’t prevent it from happening. You’ve saved me, and probably some of my loved ones, from yet another Winblows-inspired rage.

thank god for this!
drives me nuts!

now if they would only get rid of that icon that creates a new folder right next to the go up a level button… i would be happy.

I just disabled that damn Windows Update. I can go to the stupid website if I want anything. They can’t pawn shit off on me anymore now.

THANKS Jeff, I lost hours of research in open how to coding windows when I had to rush to the hospital for a family emergency and came home to find the “horror” after the horrer yet again!!!
Never to be repeated - thanks to you - YOU ROCK!!!

Thanks man, You saved me 6 hours of video encoding!

Thanks for the tip! That dialog box is real annoyance!

Thank you, Thank you, Thank you.

If you combine this evil popup with the ‘Smart Move’ mouse motion option it’s even worse - as the popup has ‘restart’ as the default button. If you are unfortunate enough to click just at the moment that the reminder pops up you get restarted without even meaning it.