DCOM, XP SP2, and Remote Debugging

I debug remotely at home, mostly because I prefer not using the crippleware version of IIS. It's kind of a pain to get it running, because you have to be more careful with permissons and configuration, but basically it works. At least, it worked until I installed XP SP2, anyway. There's a decent set of documentation on how to get Remote Debugging working under SP2, but I could not get it to work-- and I have the XP firewall completely disabled! Over and over, any attempt to remotely debug an ASP.NET app resulted in this exciting dialog box message:

This is a companion discussion topic for the original blog entry at: http://www.codinghorror.com/blog/2004/08/dcom-xp-sp2-and-remote-debugging.html

does this have any thing to do with the remote computer being Windows Server 2003? or is this the general state of things with XP SP2? It must be some case Microsoft didn’t test.

Is there supposed to be a Visual Studio update?

Thank you, thank you, thank you, thank you, thank you, thank you, thank you, thank you, thank you, thank you, and thank you.

–A fellow zombie

glad to hear it helped someone!

I suspect the disabling “ANONYMOUS LOGON” to COM was done in SP2 for security reasons. Why it is not listed in the official MS document for XP SP2 remote debugging setup, I don’t know… but there is absolutely, positively no way I could get it work until I did this…


Thanks for this workaround!!! It works perfectly…Now, I’m waiting for an official visual studio update! :slight_smile:



Is this safe?



Too bad this article is not in top Google search for the error.

You clever chappie, well done!

I also have been playing with the DCOM security settings and managed to screw my machine by removing too many permissions. Recovered by using the dcomcnfg.exe supplied with Win2k - that version seems to restore the default permissions whereas XP’s version does not! :-o

My problem is that I can’t get DCOM to work across remote machines since installing SP2, firewall is totally disabled and I’ve tried every DCOM security setting combination that I could find on the web - I think I’m going to hire a MS uber-geek to sort it out :wink:


I have the same over here. XP SP2 machines trying to debug on a W2K3 server. Have already been through everything here, but am still getting the same error! :0(

Some of my colleagues, on W2K machines, can connect to the same server without problems - so I am assuming that the problem is XP.

The server event log shows successful logon etc. So not sure what else to try. Reinstalled DTC as well (strange errors in event log), but no joy.

In VS2K3 I can manually attach a debugger to a process on the server, how is that different from the normal debug set up when F5 button is pressed!?

Am fairly sure that it is a DCOM problem, I just can’t put my finger on it!

I finally got remote debugging to work with XP SP2 by granting “Remote Access” to the ANONYMOUS LOGON account in dcomcnfg.exe on the client computer. Specifically, in
dcomcnfg.exe - Component Services - Computers - My Computer - Properties - COM Security - Access Permissions - Edit Limits.

Did you try that? Because that’s the “magic sauce” that made it work on my XP SP2. Beyond the usual checklist in the article bullets.

It’s there. Let me clarify.

dcomcnfg.exe - Component Services - Computers - My Computer - Properties - COM Security - in the Access permissions box, click the Edit Limits button.

This brings up the Access Permission dialog.

Add “ANONYMOUS LOGON” to the list under “Group or user names”, and make sure that user has “Local Access” checked and “Remote access” checked.

Just tried this, I dont even see an edit limits… mine looks like this:
Component Services - Computers - My Computer - Properties - Default COM Security - Access Permissions - Edit Default…

In here, I added Everyone, Anon login, my account…
I also tried the same in Launch Permissions… no go. Do we need a restart?

Jeff, you’re a hero! I spent a man-day on this XP SP2 problem, and never would have considered dcom security.

blimey, spot on - thanks mate

That is awesome man!

I needed to reboot the client machine for the changes to take effect.

You just saved me days of work!

How can set Edit Limits using vbscript.

Thank you, this helped me out! I hate those badly documented “security features”. Yesterday I spent the whole day trying to work around a security issue within Microsoft SharePoint, which is very hard to debug! Aargh!

Hi having same prob here but my edit limits button is grayed out!! any idea how to un gray it??